This appears not to work per the instructions in the readme.  After trying on two machines I get the same error.  

ERROR 14 Sep 2011 14:35:21 org.springframework.web.context.ContextLoader  - Context initialization failed
org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'setupSessionFactory' defined in class path resource [KB:commonsApplicationContext.xml]: Invocation of init method failed; nested exception is org.hibernate.HibernateException: Hibernate Dialect must be explicitly set

I ran the  and mysql is running.  The password in the wflow/ is correct and I tested that I can connect from the command line.  


  1. Hi Andrew:

    I had a similar error, what happen to me is that Mysql (using the defaults) was installed using port 3306 but Joget 3 Beta has by default that Mysql has port 3307.

    Other two problems that I had related to using the Joget's installation defaults were:

    1. Database name: jwdb but the mysql instructions says wflowdb

    2. For some reason the url to access Joget t after it is installed changes, instead of http://localhost:8080/wflow-wfweb I had to use http://localhost:8080/jw

    In the case of Mysql port, there are two options:

    1. Edit the file /etc/mysql/my.cnf change all the 3306 references to 3307

    2. Re-run and manually change the suggested port 3307 to 3306


    1. Things to note that in Joget v3, the context path has been changed from wflow-wfweb to jw.

      In Joget's Windows installer, it comes with MySQL embedded and it is running at port 3307 so that it doesn't clash with any existing database system running at the default port 3306. In Linux, you will need handle the database setup by yourself though. You can edit the datasource properties file for the database mapping located in the wflow folder without the need to explicitly changing the database port though.

      Hope this helps.

  2. Hi,

    Can anyone help me??.. I'm really new with linux ubuntu and Joget. Right now i'm following the instruction in v3 Knowledge Base/installation guide :

    i have no problem in doing step 1 until 5 but i cant seems to launch the . Is the any other way?.. i tried using terminal to lauch : sh /opt/joget/joget-linux-3.0.0/ and the output was -->  sh: 0: Can't open /opt/joget/joget-linux-3.0.0/

    then i tried opening it by folder and double-click the icon and choose Run and nothing happened. My third try i double-clicked it again choose Run in terminal still nothing happened.

    Please help mi,



    1. You have not rights to open it. Try it with sudo:

      $ sudo sh /opt/joget/joget-linux-3.0.0/