I've followed the setup instructions but the app wor't start.

localhost:8080/jw gives an error page

using the tomcat admin screen it shows that jwdesigner is running (and it displays a screen) but jw is stopped. Clicking the start link has no effect. It does not start.

The windows install works but I primarily want to use this on linux.

Help would be appreciated.

Thank you

  • No labels


  1. Hi Daniel, could you please attach your tomcat logs and I'll help you take a look. Those can be found in your tomcat/logs/ folder. Would be great if you could just restart your whole tomcat (just so that whatever error that's causing the jw to not start will be fairly recent). Once done just grab the catalina.out from the /apache-tomcat/logs directory and attach it here.

    1. I think that what I really need is a solid set of step-by-step procedures for how to attach the joget apps to an existing Tomcat installation. This is the way that it will have to be used in production anyway so it would be best to get this procedure down and debugged right from the start even if it was possible to get the server running in a terminal window.

      I'm very anxious to get this up and running. Any help would be greatly appreciated.

      Thank you

  2. Hi,

    I've attached the logs from tomcat6 on ubuntu and tomcat7 on windows.

    I couldn't figure out how to start your tomcat distro on linux so I can't tell if it would work like the one on windows does.

    Both of these logs is from standard installs of tomcat with your apps deployed into them.

    1. Hi there,

      Please make sure that your MySQL is up and running. I managed to replicate the exact same error by bringing down my database and starting tomcat.

      1. I'm assuming that MySql is running because on Windows I can start the tomcat from the distro (which runs in a

        DOS box) and jw runs fine. If I stop that tomcat and start the tomcat service the jw app won't run.

        No changes are made to the state of MySql during this maneuver. Also, on linux, MySql is set to start on boot up

        and I haven't done anything to stop it or interfere with it in any way. It does seem to be running because I can

        access it at any time with the MySql Admin tool.

        sorry for the hard line breaks but this editor doesn't seem to know how to word wrap.

        Any thoughts?



        1. Can you verify that in your wflow home folder in your Linux machine, the connection string and credential in the data source file is valid and can connects?

          1. I don't know but I will check as soon as I get back to that machine.


          2. The connection string and credentials seem to be ok. They work with the MySQL Query Browser.

            The jwdesigner app starts automatically as soon as it is deployed. The jw app pauses for a few seconds

            and then resumes the not_started state.

            The log files are attached.

            1. Hi Dan, it looks like the Linux user that was starting the Joget Workflow's Tomcat, is not having permission to write any file (tm.out)  to the /var/lib/tomcat6/ directory. Can you try to chmod u+x the /var/lib/tomcat6/ directory for the respective user?

              1. I've been running as root.

                I've done a new install of tomcat7

                this is the relevant directory info:

                root@DV5:/opt# ls -al tom*
                lrwxrwxrwx 1 root root 20 2011-08-05 18:04 tomcat7 -> apache-tomcat-7.0.19

                Does that help?

                1. Hi Daniel,

                  From the logs, I gather that you have Tomcat installed via apt-get, so I tried the same approach and managed to replicate the errors you're encountering on my Ubuntu machine running tomcat6. 

                  It's basically a filesystem permission issue, and I've managed to get it working. Tomcat is running using the tomcat6 user, but the tomcat directories are owned by 'root' so the tomcat6 user can't write any files into them. What I did was change the ownership of the tomcat directories accordingly, as follows:

                  sudo chown tomcat6 /usr/share/tomcat6
                  sudo chown tomcat6 /var/lib/tomcat6

                  Also, I needed to allocate more JVM heap to the default tomcat installation to prevent OutOfMemory errors, so I ran this before starting Tomcat:

                  export CATALINA_OPTS="-Xmx512m"

                  Btw, there's a linux bundle for Joget that already bundles Tomcat, and there's a step-by-step page for this over at Installing Joget 2.0 on Ubuntu Linux 10.04. That page was written for v2, but the steps are pretty similar for v3.

                  Hope this helps!

                  1. Hi,

                    I've tried everything that you suggested with v2 and v3 both on ubuntu and windows.

                    Nothing has produced any useful results. In other words, the only things I can

                    get to run are the vmware appliance and from the joget item on the windows start menu which runs tomcat in the dos box and not as a service.

                    I'm at the limit of my unix and java expertise.

                    Thank you

      2. Thank you! I have HTTP Status 404 shown on http://localhost:8080/jw and don't realize I didn't have mysql running (I set it to manual start, not as service). Now I've started mysql and then started tomcat, I can access the jw home again.

  3. i have followed the steps provided but i cant seems to lauch the startpage on my linux ubuntu...can anyone copy paste what exactly what will prompt in the terminal once the excution of setup.sh and tomcat6.sh

    please help me..