I try to start my simple process with API JSON "/web/json/workflow/process/start/essai2:3:process1", and I have this error : {"error":{"message":"","code":"404"}}.

If I execute an other URL like "/web/json/workflow/process/list" it works.

Thanks in advance


  1. I'm having the very same problem.

    Previously to the recent joget update the bellow url worked perfectly:

    http://trialjoget.trial.joget.com/jw/web/json/workflow/process/start/TESTE1:8:procReqForm (http://trialjoget.trial.joget.com/jw/web/json/workflow/process/start/

    Right now if I run the url I get the following response:{"error":{"message":"","code":"404","date":"Tue Apr 01 13:52:42 UTC 2014"}}

    Can anyone help me on this?

    1. Hi,

      This is actually a security enhancement in v4 to prevent possible Cross-Site Request Forgery (CSRF) attacks. Please refer to v4 Security Hardening and Enhancements and v4 Compatibility for more details. This is the specific change:

      JSON API Request Methods -- Previously, JSON API calls that modify the state of a process (e.g. start a process, complete an assignment, etc) support both HTTP GET and POST. In v4, only POST requests are supported to prevent cross-site request forgery (CSRF) attacks. Read-only API calls are unchanged. Please refer to the latest JSON API reference in the Knowledge Base at JSON API

      Hope this helps!

      1. Ricardo Crespo and Julian : I am facing the same issue and I tried adding the localhost in whitelist domains.Below is the link for more details. Joget V6 all Json api's are always returning 400