Joget DX Preview Release Available for Download

Check out Joget DX, the next generation successor to Joget Workflow for faster, simpler digital transformation.

 
1
0
-1

Hi,

downloaded the v5 linux tar gz file from the site and followed the installation instructions  for OSX, prequisites are all installed and tested so I know they are working but I am getting a 403 error when I try to access the localhost url for Joget. 

I took a look at the Linux steps for setup and they look pretty similar to the OSX ones, I tried modifying the app_datasource-default.properties file in the wflow directory by adding the localhost password so it now looks like this:

 

workflowDriver=com.mysql.jdbc.Driver
workflowUrl=jdbc\:mysql\://localhost\:3307/jwdb?characterEncoding\=UTF-8
workflowUser=root
profileName=
workflowPassword=password

Restarted Tomcat and still getting a 403.

Checked the log file tomcat.out and got the following;

INFO 11 Apr 2016 14:06:38 org.joget.commons.util.DynamicDataSource - datasourceName=workflow, url=jdbc:mysql://localhost:3307/jwdb?characterEncoding=UTF-8, user=root
ERROR 11 Apr 2016 14:06:38 org.joget.commons.spring.web.CustomContextLoaderListener - ===== Error initializing WebApplicationContext =====

 

Anyone any ideas?

Burnsy

    CommentAdd your comment...

    6 answers

    1.  
      2
      1
      0

      Hi,

      Seems there was a missing step in the instructions for the Community Edition, where you'll need to remove the default database configuration file before trying to setup the database. I've updated the article accordingly at Installation on Mac OSX (the last note at the end)

      Hope this helps!

       

      1. Carl Burn

        This worked for me!!

      CommentAdd your comment...
    2.  
      1
      0
      -1

      I ran into some of the same issues. Getting MySQL 6.3 CE and setting it up was easy. Plus I have the MySQL Workbench which lets me create tables, create users and so forth quickly. The only thing you have to do is set up your Joget SQL user via MySQL before running Joget. It all went very smoothly.

      I also had a half closed eyes problem. Running "sudo sh ./tomcat.sh" won't work... It needs to be "sudo sh ./tomcat.sh start"

        CommentAdd your comment...
      1.  
        1
        0
        -1

        Hi,

        thanks all. I followed the instructions provided by Julian and it works so I can now get on with figuring out how to use it effectively.

        Thanks once again for the help.

        Burnsy

          CommentAdd your comment...
        1.  
          1
          0
          -1

          I was having this same problem. It took me almost the entire flight from ATL to SFO, but I finally was able to get it working.

          The website instructions for setting up the database does not work. In the readme in the installation directory, I found the answer. In order to set up the database, you must run setup.sh. This will ask you all the questions to set up the app_datasource-default.properties file, AND it will create the database and all the tables for you.

          One more issue I had was that setup.sh runs an ANT task which invokes the mysql command and mysql bin directory was not in my path, so I had to add it.

          Good Luck!

            CommentAdd your comment...
          1.  
            1
            0
            -1

            Hi,

            yep, I thought that was odd but that is what came as "standard' in the installation so I left it in place.

            I tried altering the port number to 3306 then restarted Tomcat, went back in and still exactly the same issue.

             

            Burnsy

            1. Anders

              Hi, can you try confirming that the database login is correct? eg run mysql -hlocalhost -uroot -p in the shell with your password

            2. Carl Burn

              Tried this and was able to connect to the local MySQL server.

            CommentAdd your comment...
          2.  
            1
            0
            -1

            Hi,

            You might want to check on your database connection settings. In your properties file the workflowUrl is using port 3307. The default MySQL port is 3306 so you can try that

            workflowUrl=jdbc\:mysql\://localhost\:3306/jwdb?characterEncoding\=UTF-8

             

              CommentAdd your comment...