Joget DX Preview Release Available for Download

Check out Joget DX, the next generation successor to Joget Workflow for faster, simpler digital transformation.

Skip to end of metadata
Go to start of metadata

[catalina.2014-01-09 (1).logjoget.log.20140109|^joget.log.20140109]Hi

   I have Joget Enterprise Linux 3.1.0 installation. Recently I all my Processes could not show the workflow diagram.
   It keep showing this message.

    "Please wait while the image is being generated..."

   We did not change any of the server settings. Our server configuration is:

  1. Ubuntu 12.0.4 x64bit
  2. Apache 5
  3. MySQL 5
  4. OpenJDK 6.0 SDK

   I have actually tried the following steps in your Knowledge base, but it did not solve the problem.
   There is no problem opening the process in Workflow Designer. Only the image could not be generated/loaded.

http://dev.joget.org/community/display/KB/Joget+Workflow+v3+FAQs#JogetWorkflowv3FAQs-WhydoIkeepgetting%22Pleasewaitwhiletheimageisbeinggenerated...%22messageformyProcessthumbnail%3F\

    I even tested installing Joget 3.1.1 and OpenJDK 7.0 SDK. Still getting the same problem.

    The Joget.log & Catalina.log do seem to show any error.   ??

    I have attached a screenshot and the log files for your reference.

    I am hoping that you may have come across this problem before and knows how to solve it.
    Please let me know if you need access to the server to check it out.

     Thanks.

Best Regards
    Jimmy Loh
    Ingens Sdn. Bhd.
    jimmy.loh@ingens.com.my
    jimlohwc@gmail.com

  • No labels

10 Comments

  1. Just to be sure, did you grant enough access privilege to the working wflow directory? Maybe it has to do with permission control.

    Generated images will be stored in [joget]\wflow\app_xpdlImages\

    Cheers

  2. Hi Hugo

       I think I granted sufficient rights. This is what I did.

        > cd $JOGET_HOME
        > cd wflow
        > sudo chmod 755 ./app_xpdlImages -R
        

       Is this sufficient ? Did I miss out anything ?

       As an extra step, I have also rebooted the server after performing the above steps.

       Thanks.

       P.S.
       I have another 2 more other Joget server instances installed using the same steps. They do not have any issue with this.

    Best Regards
        Jimmy Loh

  3. Hi Hugo

        I also tried adding this option to tomcat6.sh

            -Djava.awt.headless=true

        Doesn't help either.

    http://stackoverflow.com/questions/5576986/servlet-giving-error-java-lang-noclassdeffounderror, and was resolved by adding "-Djava.awt.headless=true" into the Tomcat startup script tomcat6.sh

    Best Regards
        Jimmy Loh

    1. Hi Jimmy,

      Can you try to use the older JDK version 1.5? It might help as well.

      I don't see any related information in the log files you provided. Can you go through the steps again so that it will trigger the screenshot generation and paste the latest log files here?

      Cheers

  4. Hi,

    I'm now getting the same error, but also none of my SQLReports are being created either so I think it's linked to the graphics library or process of creating images.

    My wflow/app_xpdlImages folder contains files, but all the thumbnails are 3127b and the large files 0b.  This tells me that its trying to write to the file but failing for come reason.

    I also get the same error when I create reports.  I've checked my SQL (the tables, column names and ensured I didn't receive any errors in the log).  But on that I also receive the following error:

    javax.el.ELException: Error reading 'readyRenderPage' on type org.joget.plugin.enterprise.SqlChartMenu

    Is there a problem with my Tomcat install somewhere that is stopping it from rendering the images for both the processes and SQL Reports?

    Hugh

    1. Hi there,

      Is there anything else in the log file that you can share with us? Your setup (on the environment you set up Joget) will be useful too.

      Thanks.

      1. If there is an error with the SQL code an error is displayed in the log and the javax.el.ElException is shown on screen.

        If the SQL code is good, then no errors are shown in any Joget logs files, but the same error is shown on screen.  the only difference is that the file is created (along with the thumbnail) but no data is created.

        I'm just documenting the environment, but it's a straight forward VPS from 1&1 with very little other than the full Joget install with the included Tomcat included.

        Cheers, Hugh

        1. Hi Hugh,

          It looks like you're facing some graphics configuration issue in a "headless" non-GUI environment. Without knowing the actual environment (e.g. Linux distribution and version) and/or generated exceptions/stacktraces, it's difficult to pinpoint the required configuration.

          Did you try setting the -Djava.awt.headless=true system property for JAVA_OPTS in your Tomcat startup script?

          In some cases, you might need to your DISPLAY variable if you get an error like "http://stackoverflow.com/questions/16569364/java-headless-exception-when-i-start-java-using-a-linux-daemon" http://stackoverflow.com/questions/16569364/java-headless-exception-when-i-start-java-using-a-linux-daemon

          Cheers
          Julian

          1. Julian,

            Thanks for the reply, and thanks for helping sort the issue!!!  I'd seen the headless issue mentioned and tried to implement what I thought was the fix, but it didn't work originally.  I then followed these instructions and the SQL reports are working a treat!

            https://wiki.jenkins-ci.org/display/JENKINS/Jenkins+got+java.awt.headless+problem

            The Process images are still black (and showing the Please wait) but I think that will fix itself on the next process update or if I manually go in and delete out the images.

            For reference, this was on Cent OS without any X-server or GIU (which causes the reason for the headless).

            I can now go ahead and create some more details graphs for the client - THANK YOU!

            Hugh

            1. That's great, glad to hear that it's working now :)