i have been stucked in a problem from a week.. when ever i tried to install 3rd party libraries it always throw plugin resolution exception..here i am posting what i am doing.. please let me know what i am doing wrong. thanks this what i am executing

this is the exception i am experiencing

NOTE: i have followed these steps

If you do the above on Windows platform, please modify mvn to mvn.bat in the setup-maven.xml before executing "apache-ant-1.7.1/bin/ant -f setup-maven.xml

  • No labels


  1. Check your  (user folder)/.m2/settings.xml file.

    Last part of your error message says connection timed out to proxy.somewhere.com:8080

    1. now i am getting this issue. please help me in this

      1. File not found. Make sure that you have started the Tomcat server with Joget at least once so that the libraries will be loaded.

        1. Thank you for your great help i have installed the 3rd party libraries by running tomcat server..now when i tried to create a sample plugin using this command in console

          F:\sample>"F:\wflow-plugin-archetype\create-plugin.bat" org.joget.sample sample-plugin-pack

          i got this error message

          please let me out of this problem..thanks

          1. Hi there,

            You should be using wflow-plugin-archetype:3.1-SNAPSHOT or whichever that you built previously.

            Hope this helps.


            1. http://dev.joget.org/community/display/KBv4/Create+Userview+Theme 

              i am downloading  wflow-plugin-archetype from here.. please advise what i am doing wrong.

              1. i am trying to create a sample plugin by following link


                but when i follow i stuck in this problem

                  1. i download latest wflow-plugin-archetype from the link you refer but got the same problem again as

                    i tried to create plugin using command

                    F:\sample>D:\wflow-plugin-archetype\create-plugin.bat com.company.plugin.test TestPlugin 4.0-SNAPSHOT

                    and got this error again.. please tell me if i am missing something

                    1. Hi there,

                      You will need to go through the steps in Building from Source first. Be sure that you build the desired version.


                      1. when i tried to Build the wflow-app directory.i got following error.

                        1. Hi there,

                          You will need to follow the steps under "Install 3rd Party Libraries" in Building from Source to preload libraries used by Joget v4 first.

                          There are a lot of similar discussions in Source Codes Discussions, you may try to find what you are looking for there too.

                          When you quote your command prompt log, please try to copy the text instead of putting a screenshot as it is very hard to read and for the forum to index.

                          Hope this helps.