Joget DX Beta Available for Download

Check out Joget DX, the next generation successor to Joget Workflow for faster, simpler digital transformation.

 
2
1
0

I discovered what appears to be a bug with the Bean Shell Form Binder in a subform.  To make a long story short, the hash variables for activityId, activityName, and activityDefId contain the wrong values when access from the Load Binder of a Section in a Subform.  

Scenario:

  1. Process that asynchronously spawns 3 activities
  2. A subform with a Bean Shell Binder as the Load Binder on the first Section
  3. Version: 6.0-BETA4 - build b34bace ( I haven't tested this in other versions)

Example: Sample app that I created to demonstrate the problem.  

Activity 1, 2, and 3 are triggered when the process starts

Activities 1 and 2 are mapped to a form which has a subform .  The subform contains a Bean Shell Binder as the Load Binder on the first Section and displays the values of the activityId, activityName, and activityDefId hash variables in a text field.  Notice in the following example, that when I click on Activity 1, the header correctly indicates Activity 1, but the subform reports that the hash variables point to Activity 2. 

Activity 3 has been mapped directly to the form that has the Load Binder. In other words, there's no subform at play.  When I open Activity 3, the form correctly reports Activity 3 in both the header and hash variables.  

Of course this is just a sample application to demonstrate the problem. I encountered it while developing a more complicated application in which I need to be able to detect the current activity from within the subform Bean Shell.  Am I doing something wrong or is this a bug?

APP_demoHashVarBug-1-20171127142702.jwa

I've attached a sample application that demonstrates this problem. 

    CommentAdd your comment...

    1 answer

    1.  
      1
      0
      -1

      Hi Seth,

      Thanks for identifying and reporting the issue. It's indeed a bug where the assignment hash variable displays the wrong assignment in subforms when there are several simultaneous running activities. This should be fixed for the next release.

      Best Regards
      Julian

       

        CommentAdd your comment...